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Revision History

Revision Date Description
1.0 November 2021 | Initial release
1.1 March 2022 | Added Vulkan support

Added a known issue and workaround
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1. Introduction

VIVE Wave runtime is going to support OpenXR standard on VIVE Focus3. If you are
reading this development guide now, it means that you are the close partners with
Wave, and welcome to join OpenXR Beta trial of Wave runtime.

Since Unity 2020.3, Unity engine released the OpenXR Plug-in which allowed to
develop the cross-platform applications for OpenXR. In this guide, you will learn
how to build an OpenXR app running on Focus3 through the following step-by-step
sections.

What you will learn in this guide:

* Set up OpenXR development environment for your Unity project
* Configure VIVE Wave and Focus3 profile into your XR application
*  Build and run Unity XR application on VIVE Focus3

What Wave support on Focus3 in this release version:

*  HMD tracking pose and XR rendering
* Controller tracking pose, key input, and haptics

Okay. Let’s get started to create your 1°* VIVE Wave OpenXR content on Focus3!
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2. Development Environment

2.1.Prerequisite
Unity: Version 2020.3.15f2 and 2020.3.30f1 are verified and recommended.

Note

This guide uses Unity2020.3.30f1 with OpenXR Plugin 1.3.1 as the example.

(Optional) Android Studio: 181.5014246-windows

Note

Android Studio is used to configure your Android SDK path to Unity. See detail
in Chapter 6. You can skip if your Unity env is ready for Android already.

2.2.Create a new Unity 3D project

abD
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2.3.Build Settings

From menu File > Build Settings, switch platform to “Android”.

File Edit Assets GameObj
Mew Scene
Open Scene

Open Recent Scene

Save
Save As...

Save As Scene Template...

Mew Project...
Open Project...
Save Project

Build Settings...

Add Open Scenes

Platform

|:| PC, Mac & Lint andalone ot |'| Android

iz, :
|'| Android

: 32-hit
H—IVATEIE:

Default device = Refresh

LZ4

Learn about Unity

Player Settings... Switch Platform
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3. Package Manager

3.1.Register source server

1 From menu Edit > Project Settings
2 Select Package Manager
3 Input VIVE Registry

Name VIVE
URL https://npm-registry.vive.com
Scope com.htc.upm

4 Apply the change.

£ Project Settings

\daptive Performance Package Manager

MName
URL t ipm-registry.vive.com

com.! 10T . L2

Cancel Save

Note

All space in “URL” and “Scope(s)” must be trimmed.
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3.2.Install Wave OpenXR Feature
From menu: Window > Package Manager

1 Check sources in "My Registries”.
2 Install "VIVE Wave XR Plugin - OpenXR".

g a
VIVE Wave XR Plugin - OpenXR

Version 0.8.0-preview.1 - March 21, 2022

R's mobile of VIVE devices.

Install

3 Select “Yes” to use the Input System backends.

Warning n

This project is using the new input system package but
the native platform badkends for the new input system
are not enabled in the player settings. This means that
no input from native devices will come through,

Do you want to enable the backends? Doing so wil
*RESTART™ the editor and will *DISABLE™ the old
UnityEngine. Input APIs.

Yes Mo
4 These dependent packages will be also installed:
4.1 InputSystem 1.2.0

4.2 XR Plugin Management 4.2.1
4.3 OpenXR Plugin 1.3.1
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4. Player Settings

4.1.Change Display Orientation

From Edit > Project Settings > Player > Resolution and Presentation > Orientation
> Default Orientation, set to Landscape Left.

£ Project Settings W Asset Store

Player

Settings for Android
lcon

Resolution and Presentation
Start in fullscreen mode
Render o de safe area
Optimized Frame Pacing
Resolution Scali
Disabled
Blit Type EIS
Supported Aspect Ratio
______ tio Mode Mative Aspect Ratio

Orientation

Default Orientation® Landscape Left

Paortrait

2-bit Display Buff
Portrait Upside Down

Render Over Mative UI* Landscape Right
Shew Loading Indicator . Landscape Left

* Shared setting between multiple platfarms. Auto Rotation
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4.2.Choose Graphics APIs
Open Edit > Project Settings.

Choose Graphics APIs from Player > Other Settings > Graphics APlIs.

£ Project Settings

stive Perfarmaru Player
: splasn image
Other Settings

Rendering
C Space Gamma

Graphic

Viilkan

e OpenGLES3

Scene Template

Other Settings

Rendering
g Gamma

Graphics APls

OpenGLES3

Note

When choosing “OpenGLES3”, the Player > Other Settings > Rendering > Color
Space should be Linear.

4.3.Set Android API Level

Set the API level from Player > Other Settings > Identification.

Minimum APl Level Android 7.1 'Nougat' (AP level 25) -

Target API Level b

10
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5. XR Plug-in Management Settings

5.1.Set Interaction Profile
From Edit > Project Settings

Find OpenXR page in XR Plugin-in Management
Select Android platform tab

Press "+" button of Interaction Profiles.

Select "HTC Vive Focus3 Profile"

A W N R

£ Project Settings

ive Performance OPQHXR

Single Pass Instanced

None

OpenXR Feature Groups Eye Gaze Interaction Profile
Khranos Simple Controller Profile
VIVE Fox e Microsoft Hand Interaction Profile

i Oculus Touch Controller Profile

VIVE Focus3 Profile

All Features

Check the profile is added successfully.

tion Profiles

5 Check "VIVE Focus 3 Support" in OpenXR Feature Groups

11
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OpenXR Feature Groups

Oculus Quest Support @

Runtime Debugger

All Features

¥| VIVE Facus 3 Support @

5.2.Enable OpenXR Provider in Android

From Edit > Project Settings > XR Plugin-in Management > Android platform,
check "OpenXR".

X Project Settings

[+1

tive Performant XR Plug-in Management
(.
Initialize on Startup

Plug-in Providers @

ity
ene THl]-[_:.|;:'|-|'-l Unity Mock HMD
:ution Ord

Information about configuration, tracking and migration can be found &

Timeline

Version Control

XR Plug-in Manager
Ope ;

12
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6. Set up Android SDK

This chapter is targeted for developers who never experience in Android
development. You could skip it if you already set up Android environment.

6.1.SDK Path

From Edit > Preference > External Tools, check the "Android SDK Tools Installed
with Unity (recommended)" and copy the SDK path.

X Preferences

[+

were found. P
1e following t
ar DiffMerge

Search Service
Timeline
Ul Sealing
Android
JDK Installed with Unity (recommended)

Browse

. Tools Installed with Unity (recomme!deq)
Copy Path '
N~

13
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6.2.Android Build-Tools 29.0.2

Install the "Android SDK Build-Tools 29.0.2" to the Android SDK by using the
Android Studio.

37

o

Android Studio

—

[0l
[N ]

-
L LW

Start a new Android Studio project

Open an existing Android Studio project
¥ Check out project from Version Control
# Profile or debug APK
¥ |mport project (Gradle, Eclipse ADT, etc.)

¥ Import an Android code sample

1 Events ~ ¥ Configure

ﬂ

Appearance & Behavior » System Settings » Android SDK

Manager for th droid Studic

ndroid SDK Location: | DM\Program_Files\Unity,2020.3.15f2\Edi

Specify the Unity used SDK path.

14
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Select “Show Package Details” then you will see the list of build tools.

Show Package Details

Cancel Apply

Select the Built-Tools “29.0.2” and click “Apply”.

Appearance & Behavior » System Settings » Android SDK
Manager for the Android SDK and Toals used by Android Studio
Android SDK Location: | D:\Program_Files\Unity%,2020.3.15f2\Editc
SDK Platforms ~ SDKTools | SDK Update Sites
Below are the available SDK developer tools. Once installed, And
updates. Check "show package details" to display available versit

Mame
[129.0.0-rc3 (Obsolete)

[]29.0.1

6.3.Configure Android Built-Tools 31.0.0 (Optional)

If you used the Android build-tools 31.0.0, we noticed some problems. The
version is too high, and Unity didn't adapt it well.

Therefore you would need to
make some changes to the tools.

In the <SDK path>\build-tools\31.0.0, rename "d8.bat" to dx.bat".
In the <SDK path>\build-tools\31.0.0\lib, rename "d8.jar" to "dx.jar".

15
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7. Build and Run Unity OpenXR Sample

After Step 3.2, you can see the “OpenXR Plugin” package from Window > Package

Manager > Packages: In Project
= Pac
+~ P

Custom

JetBrains Rider Editor

OpenXR Plugin

Import the Controller sample.

You can find the Controller sample in Assets > Samples > OpenXR Plugin >1.3.1 >
Controller. Open the sample scene and go to File > Build Settings to build the
Android APK.

After installing this sample APK to Vive Focus3, you can see the controller
indicator and panels.
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8. Known Issue

1. The imported Controller sample cannot switch "Desired Tracking Origin".

[How to fix] Modify the TrackingModeOrigin.cs line.81 from & to &&.

!= m DesiredTrackingOriginMode &£& m DesiredTrackingOriginMode !=

2. The OpenXR 1.3.1 Controller sample uses Left controller’s pose on Right
Aim/Grip GUIs. You have to configure the the path as below.

o v  Aim
<} ControllerSample i .'-
& Di ional Light Tag * Layer Default

+ Tracked Pose Driver (Input System)

Rotation And Position
Update And Before Render
Position Input

Use Reference

Input Action a
I pointerPosition [RightHand XR Controller]

Rotation Input

Uze Reference
Input Action ﬂ
I pointerRotation [RightHand XR Controller]

17
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Grip

€ ControllerSample 5
tional Light Tag * Layer Default

Input Action I:I
I devicePosition [RightHand XR Contraoller]
Rotation Input
Use Reference
Input Action ﬂ
I deviceRotation [RightHand XR Controller]

18
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3. The imported Controller sample dropdown list cannot be clicked.

[How to fix] The root cause is that the Input System (1.2.0) Ul Input Module does
NOT send the Click event. To click the dropdown list, we can send the Submit
event instead of Click event.

However, the Submit event is sent only when the target object already received a
Down event. We need to send a Down event before sending a Submit event.

To accomplish the event flow, we need to send a Down event when the trigger
axis is bigger than 0.5f and send a Submit event then the trigger key is pressed.

Follow the steps below:

a. Open the <path_to_sample>/ControllerSampleActions.inputactions.
b. Select the Actions Maps “Ul” and add an action named “Down” with the
Action Type “Value” as well as Control Type “Analog”.

InputActions (Input Actions)

All Contral Scheme Auto-Save @

Action Maps + Actions Action Properties

LeftHand
RightHand I
HMD

Action
Value b

Analog -

c. Select the Path” to add a binding.

Actions

Binding Properties

Binding

Path

I <NoBindings

19
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d. Set the binding path to “trigger [XR Controller]” by specifying the Path to XR
Controller > Optional Controls > trigger.

Listen Listen

Listen

A menu

= trigger

Controller

MD
Pr on Mare
Optional Controls

Actions Binding Propertias
Binding
r [XR Controller] = T

Down
I trigger [XR Cantroller]

Binding Properties

Binding

Path  trigger

Interactions

Hold
Multi Tap
Press
Slow Tap
Tap

20
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Binding Properties

Binding

Path

21
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f. In ControllerSample > EventSystem, set the Left Click to “Ul / Down” and
Submit to “Ul / Click”.

rlj « EventSystem

Tag

-

o v

Transform

Event System

* Layer Default

Input System Ul Input Module (Script)

Mane (Transform)

Single Mouse Or Pen But Multi
Inpu ions (Input £

Mone

Ul / Down

Mone

Mone

Mone
Ul / Click

22
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9. Troubleshooting

1. The application does NOT run in VR mode.
Please check the following factors in your Unity project:

* Ensure at least one interaction profile
* Ensure OPENXR permission added in AndroidManifest

< ="org.khronos.openxr.permission.OPENXR" />

< ="org.khronos.openxr.permission.OPENXR_SYSTEM" />

e Ensure libopenxr_loader.so imported in Plugins/Android
2. Cannot click the dropdown list in Controller sample.

Please check the version of “Input System” package is 1.2.0 from Window >
Package Manager” and follow step 8.2 to solve the problem.
Input System

Version 1.2.0 - November 02, 2021

3. Cannot get the headset and controller pose in Controller sample.
Please check your Unity version. DO NOT use 2020.3.18f1.

2020.3.15f2 and 2020.3.30f1 are our recommended version for this early
access trial.

4. The scene is frozen.

Modify the file ProjectSettings > ProjectSettings.asset file. Change the value
of "runinBackground" from O to 1.

Settings:

ntion: 1

23
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5. For Unity OpenXR single-pass Vulkan case, there will be a Visibility Mask on the
right eye. (We are clarifying this issue.)

(Workaround) We can add an object with a script component to hide the
visibility mask. We need to set XRSettings.occlusionMaskScale to 0.0f at Start
and after Resume (need skip some frames).

(around

O Inspector
['L1 v Workaround
- -"_

Tag Layer Default

+ Workaround (Script)

Add Component

24
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The script is as below.

workaround.cs = X
gﬁAssembly—CSharp -

1 —| Swvstem.Collections;

2 Swstem.Collections .Generic;

3 nsing UnitvEngine ;

4 nsing UnitvEngine .ME;

0 —lpublic class workaround : MonoBehawiounr

7 1

: bool i1sResume = false:

int connter = 0;

10 ff Start is called before the first frame npdats
11 - woid Start()

12 i

13 AESettings .occlusionMaskScale = 0 .0f ;
14 E

15

16 —| woi1id DobdpplicationPanse(hool paunse

17 !

1z — 1t ({paunse == false]

12 i
20 coonter = 03
21 1 sResume = trme;
22 H
23 |
24
25 S Update is called once per frame
26 = woid Updatel )
27 H
22 —| 1T (1sResume)
29 H
30 connte r++4+;
31 — 1T {comnter == 10)
32 {
33 HESettings .occlusionMaskScale = 0 .0f ;
34 1 sResume = false;
35 H
a6 H
37 E
s 3
39

25
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